Register
Results 1 to 7 of 7

PSP not powering up and no indicator light coming up

Hi, My son PSP is not powering up and there is indication ...

  1. #1
    Member
    Join Date
    Nov 2008
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    42
    Uploads
    0

    Default PSP not powering up and no indicator light coming up

    Hi,

    My son PSP is not powering up and there is indication light coming up when pluged to the power. The machine is just like dead; any help out there?

    thanks


  2. #2
    V.I.P. Member janobi's Avatar
    Join Date
    Mar 2008
    Location
    In a field.....
    Posts
    1,615
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    5
    Uploads
    0

    Default

    Quote Originally Posted by Wale04 View Post
    Hi,

    My son PSP is not powering up and there is indication light coming up when pluged to the power. The machine is just like dead; any help out there?

    thanks

    Does it power up with the battery out? Do you get any lights at all? Has he tried to update the fw or something? When was it last working?


  3. #3
    Member
    Join Date
    Nov 2008
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    42
    Uploads
    0

    Default

    The battery does not power up the machine and when pluged to electricity the result is same, i have not updated the firmware. my thinking is either the battery is gone or the charger is not charging.......


  4. #4
    V.I.P. Member janobi's Avatar
    Join Date
    Mar 2008
    Location
    In a field.....
    Posts
    1,615
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    5
    Uploads
    0

    Default

    Quote Originally Posted by Wale04 View Post
    The battery does not power up the machine and when pluged to electricity the result is same, i have not updated the firmware. my thinking is either the battery is gone or the charger is not charging.......

    If it dont work with the power lead plugged in, then I doubt the battery is the problem. Do you know anyone else with a battery or power lead you can try?


  5. #5
    Member
    Join Date
    Nov 2008
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    42
    Uploads
    0

    Default

    Thx m8, will try that.


  6. #6
    Junior Member gazzr72's Avatar
    Join Date
    Jan 2010
    Posts
    27
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Downloads
    9
    Uploads
    0

    Default

    it sounds like your power connector/on -off switch board is faulty,these things are always going down.easily accessible from the internet and easy to change .

  7. #7
    Junior Member
    Join Date
    Jul 2010
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    0
    Uploads
    0

    Default

    i think there's a problem with your on/off/hold switch. try replacing that and it should fix the problem

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •