View Full Version : VW crafter bdm 100

31st March, 2011, 09:23 PM
A friend read crafter via bdm 100 it had no option in advance read 1255 cmd sw and when connected it said unknown ecu and he chose VW/Audi family, he read file sent to me I exported flash and ran ecu safe to remove DPF which went fine. I imported back to file saved and sent him back it got to 85% and stuck on testing block erasing block writing block, he tried writing ori which also got stuck at same point... He then took another read which read fine and write fine but obv not all data van won't start now any idea why it stuck at 85 % and can it be sorted

1st April, 2011, 08:13 AM
This can be bad read because 1255 dont support this ecu. I think you should search for ori bdm read for this ecu, then you can try to wirte it with dimsport sw.

1st April, 2011, 06:16 PM
Where can I get dimsport sw from

1st April, 2011, 06:56 PM
Try this one

1st April, 2011, 07:28 PM
Thanks will give it a go I'll post a read tomorrow if imthebone we have is corrupt

3rd April, 2011, 09:08 PM
Usually when ECU family is not recognized by BDM, then if you make a full read of ECU, the content will not include the flash, just the proc+eeprom or just the eeprom in some cases. I don't know what have you selected as an input for ECUSAFE, but I am pretty sure that you don't actually have the original flash content.

If affirmative, please let me know, I will guide you step by step in order to try to recover this ecu.

6th April, 2011, 01:11 AM
As still no luck even after Evc read and ori file processed still don't write he tried writing another software same hardware from another forum with 1255 this failed also but when connected again allowed advanced settings. Ecu was sent to me today with many scratches at bottom of board looks like he may have damaged some tracks

6th April, 2011, 07:24 PM
Update: we cleaned scratches back to copper and there looked to be no real breaks in pcb so while waiting to give it another go we had a focus 1.6 HDi ecu in for DPF removal and as bdm 100 1255 would not recognise family we decided to use Evc read the ecu DPF removed with ecusafe and back to bdmtogo and started writing and we got s failure and bdm hardwAre error so we thought the crafter ecu must have damaged the bdm tool we opened it up to check found no real problem put it back together tried again and it worked. So decided to try crafter again this got to same point and failed with bdm hardware error as we were taking it of the frame we found the problem one chip near the edge 1 leg was damaged and touching other pin we soldered back where it should be and tried again and success at last. Thanks for the help anyway.

3rd May, 2011, 09:00 PM
Hi. maybe anyone can explain why readed with external programmer(elnec beeprog2) and qfp80 adapter full dump m58bw016bd from ecu edc16 crafter not recognize ecu safe sw? p.s sorry for my bad english

22nd May, 2011, 07:45 PM
ecusafe2 is good for crafter, user new galletto obd end erased eeprom vas5054a is all ok, dpf no work

22nd May, 2011, 08:10 PM
ecusafe2 is good for crafter, user new galletto obd end erased eeprom vas5054a is all ok, dpf no work
So its necessary Vas for dpf off on this ecus ?