View Full Version : Problem with Lexia interface

27th January, 2012, 07:24 PM
Hi Guys!

I have a problem with one of my Lexia interfaces. I plug it into the USB port and nothing happens. The green LED will not even light up, and the computer does not recognize it. The USB cable is OK, as it works with other Lexia interfaces.

What could be the problem of this interface?

(if it's not a big one, I'll just repair it, but if it's more serious I'll have it replaced)

30th January, 2012, 08:58 PM
I think interface is crashed bat where is the probleme if repair or not ?
if you find a solution please contact me

13th June, 2012, 09:28 PM
Any update or help on this one?

My interface worked perfectly until I plugged it in today. No green light and laptop doesn't know its there.

Is this repairable or bin it and buy a new one?


13th June, 2012, 09:44 PM
Mine has done the same yesterday. Been reading up on it and it appears to be a common problem with the sram. Going to try changing that and will report back if it works or not.

14th June, 2012, 07:09 AM
Well, I just contacted the supplier, and he sent me a new one! :)

So my case was solved!

14th June, 2012, 08:21 AM
Well, I just contacted the supplier, and he sent me a new one! :)

So my case was solved!

Where did you buy from mate? I will buy from them if I need a new one.

I expect the usual "we have your money, now ~~~~ off" from the seller I got mine from.


14th June, 2012, 07:31 PM
PM sent :)

14th June, 2012, 10:32 PM
As predicted, no response from seller. But they replied very quickly when I asked about something from a different email address.

Hopefully this might help someone who has the same problem, or maybe I just got lucky:

I opened the interface and reflowed everything....Plugged it into laptop and same problems, no green light and no response from laptop.

Then I plugged the usb into an external 5V power only supply...green light flashed a couple of times, then stayed on solid.

Plugged the interface back into the laptop, and its alive again :)