View Full Version : kwp 2000 question

7th August, 2013, 10:04 AM

I have kwp 2000 and i want to start flashing in my Ibiza fr blt. I allready tried Reading and it work ok. Included in the kwp 2000 package came a cable with a edc 15 p ecu conector in one end, and a obd male and two crocodile cables on the other. I have 2 questions:

First question:

The cable that i supose is for bench flash is in the figure 1. But if you take a closer look in the figure 2 you will note that pins 2 e 4 are missing in the ecu conector of the cable.

I atached the pin out pdf document included in the kwp 2000 i bought. There it says pin 2 to 12 V and pin 4 to GND.

Is this cable somehow "incomplete" or am i missing something?

Second question:

If i upload to car ecu a file with wrong checksumm can i, with kwp 2000, in bench reapload original file without boot mode?


7th August, 2013, 08:16 PM
Get yourself an MPPS instead, it is great for these and has what you need incase you brick the ECU. A while back, an ECU bricked from a previous map that had been loaded, out of all my tools, only MPPS could recover it.

Boot mode is easy with these.

Look at this: Bild:VAG EDC15P P+.jpg - OBD-Wiki (http://wiki.obdtuning.com/?title=Bild:VAG_EDC15P_P%2B.jpg)

You only need 5 pins for other tools!

7th August, 2013, 10:07 PM
Thanks lewich. I am aware of mpps potential for recover bricked ecus, but i spent Money on this kwp and in the cable, since the cable came along i just wanted to know if i can recover in boot mode or not, with more or less the same procedure like mpps but with kwp 2000. It has a slow mode read and write too, like mpps, so... anyone experienced with kwp 2000? Thanks a lot.

7th August, 2013, 10:47 PM
Pick up a clone MPPS for very cheap. I tried to recover my bricked one with a KWP2000 with no joy whatsoever. Have you managed to connect with it on the bench? Try just plugging the harness on, give power to the ECU through the croc clips and try reading. Nothing can go wrong, either works or doesnt!

8th August, 2013, 04:09 PM
Ok. So conclusion is: kwp 2000 should read/write fine on bench, but recover bricked ecu in boot mode cant be done... I will try then. Thanks.

8th August, 2013, 05:26 PM
I'm not saying it won't, im saying I never had any luck. Give it a bash and report back!