PDA

View Full Version : Fiat Panda 2008 IAW4AF



ngt84
25th September, 2014, 01:17 AM
Hello there
I tried Reading the ECU Engine Data with MPPS which is from a Fiat Panda Petrol 1.2 8v 2008 IAW4AF.
Gives 320kb file, while the internet bins are 304kb...
I succesfully flashed it back and enrichened the mixture with winols but i get a dashboard fault light and with Diagnostics it displays "ECU Error"
I reflashed the original back and it works.

MPPS says it does the checksum automatically, but i guess it doesnt....
What tools do you use for this particular ECU ?


278847

betrescudan
25th September, 2014, 04:19 AM
petrol engines...fiat....allways probblems....lambda,cathalizator,dpf,....stay away please with tuning this

ngt84
26th September, 2014, 01:19 PM
Actually this is my car so i would like to play with it ;)
I didnt have any problem to enrichen the Fuels, its just the dashboard light showing an "ECU Error" right when i just turn the key on...
The MPPS has the IAW 59F option only for this Vehicle, maybe thats the culprit ?
It has only one Catalyst, with two lamdas and it goes open loop at full throtle.
See my wideband readings as stock
http://www.youtube.com/watch?v=FidshWvHGbs (https://www.youtube.com/watch?v=FidshWvHGbs)

betrescudan
26th September, 2014, 01:24 PM
try galletto 54 to write

betrescudan
26th September, 2014, 01:26 PM
you worked and lambda map?

ngt84
26th September, 2014, 11:42 PM
No, no need for lamda map, for me. Closed loop is fine @ 14.7 - 14.8
Played only with Fuel @ WOT and i got it a bit richer than i wanted ~12.3-12.8
But i was scared from the Error so i switched it to stock....
I also played with the Ignition but it is already too agressive from the factory... I already see ignition cut as it is....
Here is the stock avance after the 2nd or 3rd pull....

betrescudan
27th September, 2014, 06:21 AM
i think is a good result...diagnose with tester what said?

ngt84
27th September, 2014, 01:37 PM
MULTIECUSCAN showed ECU Error, but no visible hiccups, obviously a checksum error....
Reflashed the original file and it worked without errors...

OVERSPEED
1st October, 2014, 11:09 PM
As long as I know the problem was using 59F option... CKS was wrongly calculated

ngt84
17th October, 2014, 02:01 AM
Sure but what program - flasher tool combo should i use ?

harman1363
17th October, 2014, 08:24 AM
As already mentioned try with Galletto, it should do it without problems