PDA

View Full Version : 2010 Passat edc17cp14 bricked ..help!



badne55
1st May, 2018, 08:55 AM
I have stupidly bricked my ecu by writing map file back by obd and now car won’t start , any help would be greatly appreciated .
I read ecu by obd and mpps, sent file of and got remap file back , flashed to car but failed at 99% checksum error and ecu bricked .
I now know it’s protected , should have done more research beforehand ,
The tools I have are mpps and kess v2 I have taken ecu out and had it in benchmode with kess and I have taken backup reads of ecu , I then tried to flash orig file back with kess which seemed to all be accepted , tried in car but still exactly the same?
Any help would be great thanks

attached orig file read by mpps and bdm read with kess after damage done and id file

AVDigitale
1st May, 2018, 09:22 AM
2.12mb file bead readed
for that you bricked ecu
because mpps v18 or 21 can doing this ecu via obd without problem
flash your ecu via boot mode with ori file and try if car starting

mihaiservice
1st May, 2018, 09:29 AM
Hello
with Kess or Mpps this kind of ecu never will be fix it ! read again file in Boot mode with Fgtech or other tool !

badne55
1st May, 2018, 11:18 AM
hi thanks for reply
this ecu is tport tc1796 and mpps failed write on bad checksum and i have tried to flash original file back to ecu with kess in bootmode which wrote without errors but car still does not start and has all the dash errors

sdtsedat
1st May, 2018, 11:20 AM
You can write SGO with Vag Can Pro or Abrites or Odis. I do this job with Vag Can Pro china clone €12,-
Post picture of your ecu number i check if i have full tricore, in this case try write ori back flash by tricore and try start. If you lucky, you dont corrupt eeprom and car starts.

sdtsedat
1st May, 2018, 11:25 AM
One more thing, you cannot write by obd after 2009/06 VAG because they have TPROT

dtip
1st May, 2018, 11:33 AM
and one more thing (which i also did not know till recent and gave me hedache) KESS V2 does not read whole flash even in BOOT mode!! KTAG does, but kess don't.

badne55
1st May, 2018, 11:37 AM
here is photo of ecu other ecu data is in id filein first post

badne55
1st May, 2018, 11:38 AM
what is best tool to get to fix this as it seems i dont have the right equipment?

gabrilupo
1st May, 2018, 11:42 AM
x17 can fix it...if u can find it write an upgrade.

sdtsedat
1st May, 2018, 11:44 AM
Or Vag Can Pro or Abrites (by obd) Or need full tricore with immo off on eeprom

badne55
1st May, 2018, 11:55 AM
how would this fix with vag can pro?

sdtsedat
1st May, 2018, 11:58 AM
You can click on ecu flasher and flash sgo file, he will recover it

Verstuurd vanaf mijn SM-G955F met Tapatalk

badne55
1st May, 2018, 12:04 PM
thanks what is the sgo file and how do i get it if i got the vag can pro.
once again many thanks for your help

autoSP
1st May, 2018, 01:28 PM
u need to read OBD and boot mode. and fix file and flash in boot! now eeprom is still corrupt. then u flash obd file (ori) again via OBd and eeprom will be back good!

badne55
1st May, 2018, 02:24 PM
think i need new hardware to solve this issue , would be great if i could get a opinion of what to buy to fix this?

voltechcar
1st May, 2018, 03:29 PM
I think you have no idea what you doing, no need next ecu. You have device to flashing ecu sgo/frf file ?

badne55
1st May, 2018, 03:50 PM
you are right ,im out of my depth with this issue ,which is why i hve aske for help to try and sort it ,i have mpps and kess v2 and have ordered vag can pro as recomended by other member but willing to buy whats required to rectify this problem ,assuming that it is fixable .

voltechcar
1st May, 2018, 05:05 PM
he have this info for me so yes flashing ecu frf file get up this ecu.

badne55
1st May, 2018, 05:24 PM
sorry are you asking me to provide you a file or something ,i dont quite understand what your post means?
or are you just saying with right frf file ecu will be ok??

mihaiservice
1st May, 2018, 05:35 PM
With one FRF file (dont matter which kind of software version are ) you can update/downgrade ecu to original state !
You can use one tool like Vag Can Pro,Abritus,VVDI,ODIS or VAS PC for such FRF file.

proel
1st May, 2018, 06:01 PM
sgo file for you

sdtsedat
1st May, 2018, 08:42 PM
Flash that file with vag can pro over obd and car start again

Verstuurd vanaf mijn SM-G955F met Tapatalk

badne55
1st May, 2018, 08:56 PM
Thank you for your help I will test when my vag can pro arrives

badne55
5th May, 2018, 12:33 PM
many many thanks to proel for the flash file and to sdtsedat for all his help in solving my issue which has now been fixed thanks to him

smirnoff_rules
3rd June, 2018, 08:13 AM
You can write SGO with Vag Can Pro or Abrites or Odis. I do this job with Vag Can Pro china clone €12,-
Post picture of your ecu number i check if i have full tricore, in this case try write ori back flash by tricore and try start. If you lucky, you dont corrupt eeprom and car starts.

can you tell us options you use in vcp ? is it the edc16u34 one ?

voltechcar
3rd June, 2018, 07:29 PM
VCP --AVDI GENUINE-- VAS and other tool have option flasher. When you have srf/sgo file he flashing flash and eep and car start, simple and old. Best tool to flashing is avdi because he's stable and when you flashing ecu other number which he have vcp sometimes show error but avdi flashing always first time.

badne55
3rd June, 2018, 08:14 PM
can you tell us options you use in vcp ? is it the edc16u34 one ?

I clicked load file after the sgo box was able to be clicked and then flashed and car worked although did take over a hour to write


Sent from my iPhone using Tapatalk

badne55
3rd June, 2018, 08:14 PM
VCP --AVDI GENUINE-- VAS and other tool have option flasher. When you have srf/sgo file he flashing flash and eep and car start, simple and old. Best tool to flashing is avdi because he's stable and when you flashing ecu other number which he have vcp sometimes show error but avdi flashing always first time.

Vcp worked for me but took over a hour to flash


Sent from my iPhone using Tapatalk

voltechcar
3rd June, 2018, 08:24 PM
I know, sedat have this information for me but does nott matter. I use several time many device and to sgo/frf the best is AVDI genuine, to pcr good flashing also UHDS smok but he only flashing pcr2.1

Vmax1982
8th November, 2018, 12:06 PM
Hi there,
I have the same problem as Badne55. I followed all steps to resolve my issue but It doesn't work...
I have the same ECU EDC17CP14, (same car, same year ...)



How I get my issue -->I read with MPPS, I tried to write with MPPS an another MAP then I still can't start my car.( dash board error etc...)

Try to resolve problem -->I ask help to a friend who knows very well chiptuning etc... and he read with kess and Ktag to save files (µcontroler tricore and EEP).
He tried to write ori file with ktag, Fgtech but It doesn't work, car don't start again...
After that, we followed this post and we tried to flash with SGO file with Van can Pro 5.5.1 (doesnt work) then ABRITES (doesnt work)...


Now car doesnt start and I start to be afraid, Have you got an idea about that ?

Thanks in advance to read me.

PS : I have tried to insert ŕ picture to show you my ECU but I don't have the permission !?

Vmax1982
8th November, 2018, 12:08 PM
Hi there,
I have the same problem as Badne55. I followed all steps to resolve my issue but It doesn't work...
I have the same ECU EDC17CP14, (same car, same year ...)

570400

How I get my issue -->I read with MPPS, I tried to write with MPPS an another MAP then I still can't start my car.( dash board error etc...)

Try to resolve problem -->I ask help to a friend who knows very well chiptuning etc... and he read with kess and Ktag to save files (µcontroler tricore and EEP).
He tried to write ori file with ktag, Fgtech but It doesn't work, car don't start again...
After that, we followed this post and we tried to flash with SGO file with Van can Pro 5.5.1 (doesnt work) then ABRITES (doesnt work)...


Now car doesnt start and I start to be afraid, Have you got an idea about that ?

Thanks in advance to read me.

Vmax1982
10th November, 2018, 08:29 AM
Hi,

Nobody want to help me ?

To complete my explanation, I have 2 screenshots showing errors

570931

570932

Thanks, I really need help...

A3fDevil666
10th November, 2018, 09:37 AM
Flash whit odis

Vmax1982
17th November, 2018, 01:12 AM
Hi there,


Finally, I finished to flash by VCP and now it works.


Thanks to them who wrote this post, and gave solution and files.


Many thanks again

Smurf786
17th November, 2018, 02:01 AM
Hi there,


Finally, I finished to flash by VCP and now it works.


Thanks to them who wrote this post, and gave solution and files.


Many thanks again

Brilliant, well done... Some ecus can be a pain...