View Full Version : Volvo SID803A ECU problem (after remap?)

26th January, 2019, 08:26 PM
I've got car here, which has no power. Turbo control valve is still at 10%.
I've tried few different flash dumps with same ECU part no, sadly i haven't ori file from this car.
As i've been told, remap (dpf off) was done 4 years ago, so i don't know what is goin on here.
Now flash is ori taken from another ECU, and according to T H I S (https://www.digital-kaos.co.uk/forums/showthread.php/406011-Ford-focus-SID803A-2-0Tdci-problem-after-DPFoff-by-swiftec) topic , i tried with other eeprom dump (just with 2nd and 6 bits of 3rd line changed to immo sync) and still no luck.

So, Flash is unmodded, eeprom is unmodded, no DTC's, all parameters are ok, except turbo valve pwm , which is constant 10% .

People, help me please, because i am out of ideas

26th January, 2019, 09:19 PM
i found one topic on Polish specialist forum. Guy has same problem, the reason was broken wire from turbo actuator position sensor.
He wrote : "this SID is totally blind, you can unplug EGR, or turbo position sensor, and there is no DTC. And DTC table is full, not modified" "there is no turbo position sensor parameter to see, with any diagnostic tester"

26th January, 2019, 09:52 PM
That is true!
Have one in my garage and forgot to put connector for TVA back and there are no errors but car got noise when turn off.Try it with 3 diagnostics and no dtc!?

27th January, 2019, 10:33 AM
self turbo actuator position sensor also can be reason why its not works, i have changed a lot of them on 2.0d

27th January, 2019, 10:34 AM
Crap! Sadly it's Sunday, I have to w8 till tomorrow

19th February, 2019, 01:37 PM
yep, broken wire....