OPCOM X17DTL diagnose
Register
Results 1 to 4 of 4
  1. #1
    Senior Member makadam's Avatar
    Join Date
    Nov 2010
    Location
    EUROPE
    Posts
    279
    Thanks
    87
    Thanked 59 Times in 13 Posts
    Downloads
    6
    Uploads
    0

    Default OPCOM X17DTL diagnose

    I just buy OPCOM (chinesse clone with 1.39 firmware) and using OPCOM081016_EN software but there is some problem when trying to connect to body module (instrument, airbag, engine coolant, central door locking) on ASTRA G 1999 X17DTL.After some time there is a message>
    Changing Init Address....!

    The same unit with the same software works without problem to the same module on X12 ASTRA G 1998.

    OPCOM use pin12 for communication to this module.
    Also I cant diagnose VP44 pump in the same car (PSG5).
    I also try to use another software version 090820b with the same result and with this version the unit doesn't work in X12 Astra when using body instrument module.

    Can someone tell me what is the problem with that car?

    BTW Engine diagnostic works fine!

  2. #2
    Top Poster
    Join Date
    Jan 2010
    Posts
    163
    Thanks
    0
    Thanked 18 Times in 5 Posts
    Downloads
    2
    Uploads
    0

    Default

    VP pump you cannot read (16 pin diagnose connector not work)
    You have to connect the interface on pump connector wire (pin 9)

  3. #3
    Senior Member makadam's Avatar
    Join Date
    Nov 2010
    Location
    EUROPE
    Posts
    279
    Thanks
    87
    Thanked 59 Times in 13 Posts
    Downloads
    6
    Uploads
    0

    Default

    The problem is when I try to connect to pin12 KW82 the message appears Changing Init address....!
    Somewhwre I read that I must chenge some resistor on the interface v3.

  4. #4
    Senior Member makadam's Avatar
    Join Date
    Nov 2010
    Location
    EUROPE
    Posts
    279
    Thanks
    87
    Thanked 59 Times in 13 Posts
    Downloads
    6
    Uploads
    0

    Default

    Just want to confirm that replacing R32 10k resistor with 510 ohm resistor resolve the problem connecting OPCOM V3 (yellow plate) using KW82 protocol and pin 12 on Astra G 1999 X17DTL
    Last edited by makadam; 28th March, 2011 at 05:53 PM.

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •