iPod touch updates are not currently in sync with the latest iOS updates and its really annoying.

I fancied using my iTouch for a logging app called hamlog which requires a minimum update level which cannot be achieved through official Apple updates.

4.2.1 - current iOS for iTouch
4.3.5 or "iOS 4.3" - required iOS for app

I have tried the iFile trick of editing system/library/coreservices/systemversion.plist and changing the iOS version to 4.3.5 and that allowed the app to install but it turns out the app needs a feature of the new iOS and isnt just requesting it for the sake of it.

I feel like apple have got me in a corner now, very annoyed.

Im sure there is a workaround, any thoughts???