Chrysler 300c 3.0 crdi Cold start improve
Register
Results 1 to 3 of 3
  1. #1
    DK Veteran

    Join Date
    Nov 2011
    Location
    EU
    Posts
    1,129
    Thanks
    405
    Thanked 183 Times in 136 Posts
    Downloads
    338
    Uploads
    1

    Default Chrysler 300c 3.0 crdi Cold start improve

    Hi

    This car starts perfectly when warm and after 5-6 hours again problem.... You have to crank long time... I think fuel is the problem.
    Glow plugs are new and they work okay. I check fuel pipes, but I can not find the problem, fuel fitler is new... There is no any light or dtc on car...

    So here I attach file if someone can make any mod for better cold start.

    https://ufile.io/7bwe7

    file uploaded to ufile, because I can notattach it on site
    Last edited by bugarcek; 6th December, 2018 at 09:20 AM.

  2. #2
    DK Veteran
    atomiczen's Avatar
    Join Date
    Apr 2012
    Location
    Wonderland
    Posts
    1,098
    Thanks
    71
    Thanked 359 Times in 142 Posts
    Downloads
    121
    Uploads
    0

    Default

    check fuel pressure, you have injector faulty or a high press fuel pump that don't reach the fuel target

  3. #3
    DK Veteran

    Join Date
    Nov 2011
    Location
    EU
    Posts
    1,129
    Thanks
    405
    Thanked 183 Times in 136 Posts
    Downloads
    338
    Uploads
    1

    Default

    Can be this increased somehow? Because hot start imediatelly without any problem and friend have this car from new, it has only 90.000 km.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •