Sony Vizio won't power on after sitting in storage
Register
Results 1 to 2 of 2
  1. #1
    Newbie
    Join Date
    Dec 2009
    Location
    killumbus onio
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Sony Vizio won't power on after sitting in storage

    Any electronic or tv repair techs can give me a idea where to start it won't power up n power cycling won't change it....once the Vizio logo lit up but only once

  2. #2
    Newbie
    Join Date
    Dec 2018
    Posts
    6
    Thanks
    5
    Thanked 1 Time in 1 Post

    Default

    I am no tech neither an electrician, i've seen ur post and thought i'll give my opinion, sorry if it won't help you tho.

    You said the TV sit for a while in storage, and based on the month we are in, i assume it was cold where the TV sat, did you moved the TV in a warmer room and fired it right up, or you gave it time to dry up ? it might have produced condensation, maybe not visible on the outside but on the inside, and you shorted it.
    the logo you've seen for a short time was a good indicator.

    Second thought would be, you have puffed/broken capacitors. If you can take off the cover and take look if you see any visible damage on the back of it, BE CAREFUL TO TAKE OUT THE POWER CORD and NOT TO TOUCH ANYTHING THAT CONTAINS VOLTAGE.

    Sorry if my answer are somehow irrelevant to ur problem.
    Last edited by kurva; 18th December, 2018 at 09:54 PM.

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •