Volvo v50 immo problem
Register
Results 1 to 10 of 10
  1. #1
    Junior Member
    Join Date
    Jun 2016
    Posts
    22
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default Volvo v50 immo problem

    The car is Volvo v50 2005year 2.0D
    After repairing the steering column lock module the car doesnt start.
    On the dash there is an Immo error.
    The immo ecu has errors:
    6C47 - control unit steering column locking, incorrect signal
    6C53 - Control unit steering column locking, internal
    The engine ecu has no faults.
    The battery was changed with a new one while the module was beeing repaired.
    Now the steering module has no power.
    Is it possible ECU and CEM to have lost sync and thats why there is no power to the steering module?

  2. #2
    DK Veteran
    brend's Avatar
    Join Date
    Oct 2015
    Location
    Same where
    Posts
    7,507
    Thanks
    2,308
    Thanked 3,933 Times in 3,049 Posts

    Default

    Steering lock have security information.
    Without programming it's not work and this job not simpel.

    About information for ask ...........
    http://www.digital-kaos.co.uk/forums/announcement.php?f=174&a=32

    First read rules ........................


  3. #3
    Junior Member
    Join Date
    Jun 2016
    Posts
    22
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default

    Could that be the reason there is no power to it?
    Power to the lock module comes from the CEM.
    My question is if the engine ecu and CEM lost sync, can that be the reason for the CEM not to send 12V to the lock?

  4. #4
    DK Veteran
    brend's Avatar
    Join Date
    Oct 2015
    Location
    Same where
    Posts
    7,507
    Thanks
    2,308
    Thanked 3,933 Times in 3,049 Posts

    Default

    This job can't go thinking away.
    For more anderstand need check ecu/cem immo status and it's go diagnostiks equpment away or dump away.

    Quote Originally Posted by Nqkaf View Post
    Could that be the reason there is no power to it?
    Power to the lock module comes from the CEM.
    My question is if the engine ecu and CEM lost sync, can that be the reason for the CEM not to send 12V to the lock?

    About information for ask ...........
    http://www.digital-kaos.co.uk/forums/announcement.php?f=174&a=32

    First read rules ........................


  5. #5
    DK Veteran
    waldi1979's Avatar
    Join Date
    Dec 2010
    Posts
    2,031
    Thanks
    355
    Thanked 1,037 Times in 664 Posts

    Default

    The power come from CEM just for a moment, when the steering lock is opened or closed.
    Probably you know it but I remind you.

    If I help you, please press
    THANKS button.

  6. #6
    Junior Member
    Join Date
    Jun 2016
    Posts
    22
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default

    Yes it does come for a second.The LIN has signal too.I tried the car again and got a new error in the engine ecu - C326. So i guess now this confirms that i have to sync engine ecu and CEM.

  7. #7
    Junior Member
    Join Date
    Jun 2016
    Posts
    22
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default

    Does anyone know if a second hand steering lock module needs adaptation

  8. #8
    Top Poster
    Join Date
    Aug 2015
    Posts
    123
    Thanks
    2
    Thanked 44 Times in 42 Posts

    Default

    if you not done what is written in post2 . the car will not start.

  9. #9
    Junior Member
    Join Date
    Jun 2016
    Posts
    22
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default

    Problem was solved, the SCL was removed from the software.

  10. #10
    Member
    Join Date
    Sep 2009
    Location
    Hungary
    Posts
    96
    Thanks
    3
    Thanked 1 Time in 1 Post

    Default

    Quote Originally Posted by Nqkaf View Post
    Problem was solved, the SCL was removed from the software.
    How did you do it? Which program did you use? Did you modify the CEM or the ECU? I have the same problem and I am going crayz slowly ...

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •