Digiprog 3 v4.94 : writing fails but I can read fine. Working an 06 Silverado 1500
Register
Results 1 to 2 of 2
  1. #1
    Newbie
    Join Date
    Jun 2019
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    0
    Uploads
    0

    Default Digiprog 3 v4.94 : writing fails but I can read fine. Working an 06 Silverado 1500

    Hello I am working on a 2006 silverado, I took the dash apart and located the Atmel eeprom it has Atmel 506 04114 a 4g15860 on it. I am using the ST01 clip and I am able to read the memory just fine by going to the EEPROM menu on the digiprog by going to SET TYPE>95>95020. I checked out the hex dump and the VIN matches up perfectly. Now writing to it in anyway is not working. I first tried writing it via the CAR/TRUCK menu Chevrolet>Avalanche and the old mileage is displayed perfectly but whenever i enter the new value there is no error but it displays a prompt to check the new mileage and it is the same one. I read some threads which suggested to try writing it as a Tahoe but the KM displayed is completely wrong so I did not try entering a new value. Now I also uploaded an edited hex file with the new values and when writing it gets to about half way and it displays a big ERROR.

    So beside the obvious question about whether I can do anything to fix it, I read that the digiprog writes to my specific atmel chip a bit too fast so the verification process fails which is what I suspect might be going on but I also thought it may be the connections, ive tried two different SOIC 8 clips and still nothing. Also I have abig question, why is this specific chip have 506 printed on it but on the Digiprog it is listed as S95P04 and under eeprom it is under 95020? Also when I try googling the chip atmel 506, I see no results except for chips AT25020? Why all the different names?

    Last but not least, are there any no bullshit programmers out there with good support for American, asian and european vehicles? Thanks

  2. #2
    Newbie
    Join Date
    Jun 2019
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Downloads
    0
    Uploads
    0

    Default

    I should mention that I have done a 2003 silverado before with this device.

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •