Transit custom 2.0 130ps p228c code need help please - Page 2
Register
Page 2 of 2 FirstFirst 12
Results 16 to 28 of 28
  1. #16
    Member
    Join Date
    Nov 2019
    Posts
    63
    Thanks
    20
    Thanked 1 Time in 1 Post

    Default

    Will not allow me to upload pictures
    Code: p228c - fuel pressure regulator a exceeded control limits - pressure too low

    Additional fault symptoms:
    - missing calibration
    Last edited by Jamaly; 30th April, 2020 at 10:48 PM.

  2. #17
    DK Veteran

    Join Date
    Dec 2009
    Location
    Portugal
    Posts
    394
    Thanks
    123
    Thanked 195 Times in 156 Posts

    Default

    on the valve try to measure the resistance if it has 6 ohm is in order, with the plug disconnected.
    by the description of the fault it is lack of fuel, and it must give fault when you pull by the van.
    Anyway in my opinion you should try a new diesel filter.
    Last edited by rui; 30th April, 2020 at 11:38 PM.

  3. The Following User Says Thank You to rui For This Useful Post:

    Jamaly (2nd May, 2020)

  4. #18
    DK Veteran

    Join Date
    Jul 2013
    Location
    yorkshire
    Posts
    882
    Thanks
    79
    Thanked 231 Times in 210 Posts

    Default

    Do these have a in tank pump?

  5. #19
    Member
    Join Date
    Nov 2019
    Posts
    63
    Thanks
    20
    Thanked 1 Time in 1 Post

    Default

    Hi replaced fuel filter today still same issue

  6. #20
    V.I.P. Member
    Meat-Head's Avatar
    Join Date
    Oct 2009
    Location
    Meatheadshire (Between London and Scotland)
    Posts
    31,955
    Thanks
    8,557
    Thanked 5,933 Times in 4,689 Posts

    Default

    Can you run it off external fuel can

    has some inbred crush fuel line?

    if you drive up/down your street like your stalking no throttle, just in 1 gear code?

    then if you drive it like your trying to get home to log on dk, does it cut dead?

    Was Banned For Being Certifiably Insane and Stupid

  7. #21
    DK Veteran

    Join Date
    Dec 2009
    Location
    Portugal
    Posts
    394
    Thanks
    123
    Thanked 195 Times in 156 Posts

    Default

    Did you come to do the regulator test if it is in order?
    Did you find small metal particles (filings) in the old filter?
    Before the repair, did he have this malfunction or did it appear now?

  8. #22
    Member
    Join Date
    Nov 2019
    Posts
    63
    Thanks
    20
    Thanked 1 Time in 1 Post

    Default

    Not done regulator test yet.
    Did not have this issue before went in for repairs.
    And code isnt present until i accelerate then goes into limp mode

  9. #23
    DK Veteran

    Join Date
    Jan 2010
    Location
    EU
    Posts
    510
    Thanks
    199
    Thanked 147 Times in 93 Posts

    Default

    On the right side of the fuel rail there is the PRV - pressure relief valve - on this engines it always go bad an you will lose fuel pressure. When FRP is bad you cannot do any calibration because the rail pressure is alway changing.
    PRV is going bad when SCV - suction control valve goes bad. I suggest to check and replace both. You can check the PRV by simply remove the fuel return line from it and start the car, there should be no fuel running out from the PRV . ( Put the fuel return line in a bottle or fuel will run out everywhere)

    https://workshop-manuals.com/ford/tr..._relief_valve/
    Last edited by ollync; 2nd May, 2020 at 10:56 PM.

  10. The Following User Says Thank You to ollync For This Useful Post:

    Jamaly (3rd May, 2020)

  11. #24
    Member
    Join Date
    Nov 2019
    Posts
    63
    Thanks
    20
    Thanked 1 Time in 1 Post

    Default

    Hi that link refers to a 2006 van mines 2016 euro 6 is it ssme

  12. #25
    DK Veteran

    Join Date
    Jan 2010
    Location
    EU
    Posts
    510
    Thanks
    199
    Thanked 147 Times in 93 Posts

    Default

    Sorry, didn't see year and engine. Tought it is 2.2 TDCI

  13. #26
    Member
    Join Date
    Nov 2019
    Posts
    63
    Thanks
    20
    Thanked 1 Time in 1 Post

    Default

    No problems is it same issue though as guys that apparently rebuilt engine changed fuel rail and injectors what they have told me

  14. #27
    Top Poster
    Join Date
    Jul 2018
    Posts
    136
    Thanks
    22
    Thanked 8 Times in 7 Posts

    Default

    Hi there, how did you fixed your problem coz i got a same one now after rebuild engine

  15. #28
    Member
    Join Date
    Oct 2015
    Posts
    56
    Thanks
    23
    Thanked 3 Times in 3 Posts

    Default

    Hello. I have the same error, tried with original VCM II to reset but there is no option for that, only reset high pressure values which is for FRP only, not for regulator. How did you solve it?

    Sent from my M2007J1SC using Tapatalk

 

 
Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •