Register
Results 1 to 10 of 10
  1. #1
    DK Veteran

    Join Date
    Jun 2013
    Location
    EU
    Posts
    4,207
    Thanks Thanks Given 
    1,362
    Thanks Thanks Received 
    2,698
    Thanked in
    1,561 Posts

    Default Volvo V50 CEM ECU ABS syncro need help, dumps attached.

    Hi.

    Here dumps of ECU Eeprom, ABS module Eeprom, and CEM eeprom.

    Can someone check if they are correct, and they are married and sync.

    If not married and sync, can someone please marry and sync.

    Problems after battery removed for days. CEM reports not connection with engine ECU on CAN. And car not start.

    thanks in advance.
    Attached Files Attached Files
    Last edited by morgano; 4th August, 2020 at 11:03 PM.

  2. #2
    DK Veteran

    Join Date
    Jun 2013
    Location
    EU
    Posts
    4,207
    Thanks Thanks Given 
    1,362
    Thanks Thanks Received 
    2,698
    Thanked in
    1,561 Posts

    Default

    Anyone?

    To me all ecus are sync but maybe i am missing something.

  3. #3
    DK Veteran

    Join Date
    Nov 2009
    Posts
    1,007
    Thanks Thanks Given 
    249
    Thanks Thanks Received 
    145
    Thanked in
    84 Posts

    Default

    Trying to help

    You only need ABS ID not eeprom
    Reference of engine Ecu is basical....in my case using codecard sync utility is different choice if SID803 ETC....

    Then we can check if they are really sync or not.

    Hope it helped.

  4. The Following User Says Thank You to GolfmkI For This Useful Post:

    morgano (5th August, 2020)

  5. #4
    DK Veteran

    Join Date
    Nov 2009
    Posts
    1,007
    Thanks Thanks Given 
    249
    Thanks Thanks Received 
    145
    Thanked in
    84 Posts

    Default

    CHECKED RIGTH NOW

    If SID803 Ecu in my opinion sync is not good
    We also need ABS ID (CHECK WITH DIAG) to make proper Job

    I can see also the CEM read file is PROBABLY BAD READ?

    Sync data should be on line 130
    You have it on 530 because the first 000-3ff are simply FF

    CEM SYNC: 00 73 35 72 31 67
    ECU SYNC: 31 35 08 10 18 77
    ABS ID: 00 70 15 01 05 14

    So sync is not ok
    Put ABS ID to be 100% sure and Ill try to help you.

    Sorry if I am wrong , simply trying to help

  6. The Following User Says Thank You to GolfmkI For This Useful Post:

    morgano (5th August, 2020)

  7. #5
    DK Veteran

    Join Date
    Jun 2013
    Location
    EU
    Posts
    4,207
    Thanks Thanks Given 
    1,362
    Thanks Thanks Received 
    2,698
    Thanked in
    1,561 Posts

    Default

    Ecu is edc16c34 fomoco, it is from a 1.6 engine

    I saw in CEM sync words are at address 0x530.

    On ecu eeprom the syncro field is repeated 3 times in the very begining of the dump after the version info. Field is CEM sync + 00 + ABS id + 03 + chksm

    Also the abs id can be found in abs module eeprom dump with little trick, just inverse all bits in dump and the id can be found.

    Can it be the ecu being in some kind of service mode and standard diagnose cannot put it out?

    If i connect galletto to obd port and choose ford focus edc16c34 ecu can communicate with it, but only gives dots as ecu info. So can is working. Cem seems not to be able to exchange data with ecu. But cem can talk with steering for example that is on same can bus.





    Attached Images Attached Images
    Last edited by morgano; 5th August, 2020 at 03:39 PM.

  8. The Following 2 Users Say Thank You to morgano For This Useful Post:

    jomberykaso (22nd May, 2024), Pirate08 (13th January, 2022)

  9. #6
    DK Veteran

    Join Date
    Nov 2009
    Posts
    1,007
    Thanks Thanks Given 
    249
    Thanks Thanks Received 
    145
    Thanked in
    84 Posts

    Default

    You are rigth
    I was checking my notes about SID803

    iF EDC16C34 SYNC SEEMS OK!!

    Car is crancking?
    Perhaps CEM module /Ecu is damaged???

    Ive played with this problem before on Ford..

    In theory sync was ok,2 keys in memory, but not starting/crancking...

    When this happened to me Ecu was the problem, didnt Know if HW or SW

    But this is VOLVO didnt Know if its the same...
    What about Keys and ESL
    Keys are recognised by Cem? ESL unlock?
    I remember some problem with ignition switches on VOLVO.

    You could also consider there is a FLASH problem?
    Cem/Ecu flash problem?
    Causing CAN COMM problems...

    I really cant help you more I think, but I assume SYNC IS OK and it seems ok...

    Good luck!
    Last edited by GolfmkI; 5th August, 2020 at 03:59 PM.

  10. The Following User Says Thank You to GolfmkI For This Useful Post:

    morgano (5th August, 2020)

  11. #7
    DK Veteran

    Join Date
    Jun 2013
    Location
    EU
    Posts
    4,207
    Thanks Thanks Given 
    1,362
    Thanks Thanks Received 
    2,698
    Thanked in
    1,561 Posts

    Default

    CEM recognize keys as OK, but complains about cannot find engine control unit on CAN.

    Starting to think the CEM must be faulty. We exchanged edc16c34 by another one, and teves ABS MK60 with another one, result is same as with original componets (we cloned both before install).

    Or some special trick to make the ecu and the cem become friends again and start a nice talk over can bus. We were told this fault normally in volvo dealer solve by realigning all ecus, but how to realign if cannot
    connect on diagnose with them?

  12. #8
    DK Veteran

    Join Date
    Jun 2013
    Location
    EU
    Posts
    4,207
    Thanks Thanks Given 
    1,362
    Thanks Thanks Received 
    2,698
    Thanked in
    1,561 Posts

    Default

    Solved!

    Finally was wiring issues.

    Fixing then made the car start.

  13. The Following 2 Users Say Thank You to morgano For This Useful Post:

    pinotec (7th August, 2020), rafal (16th October, 2020)

  14. #9
    Newbie
    Join Date
    Aug 2020
    Location
    Sweden
    Posts
    5
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    Quote Originally Posted by morgano View Post
    Solved!

    Finally was wiring issues.

    Fixing then made the car start.
    hi can you help with my car i have volvo v50 2.0d i have same problem what wire is problem

  15. #10
    DK Veteran

    Join Date
    Jun 2013
    Location
    EU
    Posts
    4,207
    Thanks Thanks Given 
    1,362
    Thanks Thanks Received 
    2,698
    Thanked in
    1,561 Posts

    Default

    Quote Originally Posted by Santino993 View Post
    hi can you help with my car i have volvo v50 2.0d i have same problem what wire is problem
    Was loose pins on connector header abs harness.

  16. The Following User Says Thank You to morgano For This Useful Post:

    pinotec (5th September, 2023)

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.