Corrupted BIOS - Lenovo x121e (after reflashing BIOS WiFi doesn't work)
Register
Results 1 to 3 of 3
  1. #1
    Newbie
    Join Date
    Mar 2018
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Corrupted BIOS - Lenovo x121e (after reflashing BIOS WiFi doesn't work)

    Hi, I got some problems with my Lenovo X121e with Intel Core i3 (MB: DA0FL8MB8C0 REV: C ).
    I got random shutdowns so I reflashed only BIOS, later BIOS and EC with dump from Vinafix and even after only BIOS reflashing computer works but WiFi isn't.

    Tried so many different things like changeing ME region (all BIOS parts from donor and mine ME region) but still WiFi doesn't work.

    What I can do about it?

    I tried so many different combination - even BIOS upgrade under Windows doesn't help in both cases - with my old bios and new.


    Can anyone help me?

    Tell me what to do or prepare .bin for reflashing BIOS chip? (of course I have programmer TL866)


    Tried some things like changeing some regions using Flash Image Tool but nothing I did worked :/
    Attached Files Attached Files
    Last edited by folxsgalaxy; 8th October, 2020 at 12:57 AM.

  2. #2
    Newbie
    Join Date
    Sep 2020
    Location
    USA
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I think you better go to the service center. I heard that there are a lot of problems with Lenovo laptops. The first few years, Lenovo produced equipment of decent quality, and now they have rolled down thoroughly.

  3. #3
    Newbie
    Join Date
    Mar 2018
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I did it. Just had to turn on the radio using FN + Fx key and turn on all radios like WLAN/BLUETOOTH etc.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •