Locked my ECU while flashing
Register
Results 1 to 5 of 5
  1. #1
    Newbie
    Join Date
    Feb 2021
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Locked my ECU while flashing

    Hi all.

    I was playing with my car today and apparently it resulted in locked ECU after flashing.

    I have flashed a little bit edited file (basically the km data changed from the old KM bin file, so there is exact mileage).

    Flash finished, car stars, cluster does not light up. Cannot get the communication with ECU through OBD.

    I am using old version of SMOK, Volvo tool.

    The car is Volvo S80, D5, from 2007 if it helps.

    How to get to the ECU and cluster working properly again?

  2. #2
    DK Veteran

    Join Date
    Nov 2009
    Posts
    557
    Thanks
    32
    Thanked 140 Times in 128 Posts

    Default

    Find someone who will repair it. You can damage something else trying to fix and make bigger problem.

  3. #3
    DK Veteran
    figani's Avatar
    Join Date
    Feb 2018
    Location
    47 45 52 4D 41 4E 59
    Posts
    1,704
    Thanks
    241
    Thanked 708 Times in 567 Posts

    Default

    Quote Originally Posted by manlu View Post
    Hi all.

    I was playing with my car today and apparently it resulted in locked ECU after flashing.

    I have flashed a little bit edited file (basically the km data changed from the old KM bin file, so there is exact mileage).

    Flash finished, car stars, cluster does not light up. Cannot get the communication with ECU through OBD.

    I am using old version of SMOK, Volvo tool.

    The car is Volvo S80, D5, from 2007 if it helps.

    How to get to the ECU and cluster working properly again?
    Did you try unplug battery for some time...?

  4. #4
    Newbie
    Join Date
    Feb 2021
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by figani View Post
    Did you try unplug battery for some time...?
    Yes, I did.

    I suspect my battery went down during the process and flash somehow became corrupted. No errors while flashing tho.

    if it helps, my ECU is BOSCH EDC 16C31

  5. #5
    DK Veteran
    figani's Avatar
    Join Date
    Feb 2018
    Location
    47 45 52 4D 41 4E 59
    Posts
    1,704
    Thanks
    241
    Thanked 708 Times in 567 Posts

    Default

    connect it by pinout on bench...
    and try to get communication...

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •