The PIA VPN (Private Internet Access VPN) app is known to be buggy, very buggy. It's fine if you're using a mainstream device (Windows, Linux and major android phones from Samsung, etc). But outside of that small sphere of existence you're in for a headache.

I'm hoping to share my struggles so anyone who uses this worthy service and tries to install the app on a box. It might save your sanity.

First off, it will work. You just have to remember a simple rule... it lies to you. Not deliberately, it's just confused.

On my X96 max+ (possibly a max +2) the biggest issue was on the connection. Goes green (connected) them turns orange (trying to connect to server) and just hangs there. In most cases just wait. If you get a VPN IP address at the bottom of the display, you're connected even if the icon is orange.
A simple way to check is to use Speed test by Ookla.
It also had a habit of not starting/connecting on boot/startup. Always check with speed test or another test app.

My bigger issues came with my new box (H96 8/128GB RK3566) that runs Android 11 and the new PIA app.

First off the app wouldn't open. That needs the battery monitoring option to be turned off for the app (even though there's no battery in the box to monitor). That's hidden deep in the android setting menus somewhere.
If at any time the app crashes, and it will, you will need to exit via the home button on the remote... put the box in to standby (power button)... unplug then plug in the power lead. DO NOT CLEAR THE CACHE OR DATA from the app.

If after entering your login details the connection hangs when it should take you to the main app screen... Press the home button on the remote and power button once on the android start screen, etc
When you go back into the PIA app you will be logged in and it will take you straight to the main app page.

I have been unable to select the Wireguard option. This was also an issue with my X96 max +. Probably due to the processors or chinese butchery of the os.

When trying to change from the Automatic server selection the app always crashed. I eventually worked out a solution. Disconnect the VPN connection (icon turns red)... Go to your preferred server and select it. The app would always crash at this point... Press the home button on the remote and power button once on the android start screen, etc...
Once you're back in the app it should connect up but will show the Automatic Setting ticked... it lies. When I checked the connected server using Speed test it was on my preferred server but used a server in Norway (the Automatic selected server country) to run the speed test.
This could be for one of two reasons... I don't allow Speed test access to my location... or the app is so screwed up it doesn't know whats up, down, left or right.

I always select start on boot, connect on start and connect after update. So for it has worked as expected. I did get one issue when the box was left on standby for most of the day and the VPN failed to connect. That might be an auto disconnect from the server due to no use, or the app spat it's dummy ouit, again.
Either way I entered the app hit the connect button and it worked... it said I was connected to Norway again but speed test showed my manually selected UK server.

Never trust the app to start up on boot or auto connect. I Always check it with speed test to make sure it started.

There is another way to use PIA VPN without the app. But that requires manually setting up the VPN within android or installing an app that will allow you to manually set up a VPN connection.
The biggest issue with this is the headache it will cause you getting it to work. And if your chosen server decides it doesn't want to play due to an internal fault, you'll be without your VPN unless you manually change the settings for another server.

I know this sounds like PIA VPN might not be the best choice due to app support. But overall it's a reliable service. I've used this for many years on my old Windows 7 (until they dropped the support due to Win7 being outdated), several versions of Linux and two flagship Samsung phones. All work without any issues. It's just once you leave the mainstream devices PIA just don't want to spend the time or money to make the app stable.

I hope someone finds this of use.